summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 16 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d1edda028c2..526c7d517603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# This PKGBUILD is based on the official Arch cmake package.
pkgname=cmake-git
-pkgver=3.10.0.rc2.91.g6dec363028
+pkgver=3.27.4.645.g72beefa91b
pkgrel=1
pkgdesc='A cross-platform open-source make system'
arch=('x86_64')
@@ -17,13 +17,14 @@ url="http://www.cmake.org/"
license=('custom')
conflicts=('cmake')
provides=('cmake')
-depends=('curl' 'libarchive' 'shared-mime-info' 'jsoncpp' 'rhash')
-makedepends=('qt5-base' 'python-sphinx' 'git' 'ncurses' 'emacs')
-optdepends=('qt5-base: cmake-gui'
- 'libxkbcommon-x11: cmake-gui')
-source=('git+https://cmake.org/cmake.git')
-md5sums=('SKIP')
-shortver=$(printf "${pkgver}" | sed 's/\([0-9]\+\.[0-9]\+\)\..*/\1/')
+depends=('curl' 'libarchive' 'hicolor-icon-theme' 'jsoncpp' 'libjsoncpp.so' 'libuv' 'rhash' 'cppdap')
+makedepends=('qt6-base' 'python-sphinx' 'emacs' 'nlohmann-json' 'git')
+optdepends=('qt6-base: cmake-gui')
+source=('git+https://gitlab.kitware.com/cmake/cmake.git'
+ 'cmake-cppflags.patch')
+md5sums=('SKIP'
+ 'd7316e540d07e0a7ebce75951a7b2697')
+#shortver=$(printf "${pkgver}" | sed 's/\([0-9]\+\.[0-9]\+\)\..*/\1/')
pkgver() {
cd "$srcdir/cmake"
@@ -32,15 +33,19 @@ pkgver() {
prepare() {
cd "$srcdir/cmake"
+ patch -p1 -i ../cmake-cppflags.patch # Honor CPPFLAGS https://gitlab.kitware.com/cmake/cmake/issues/12928
}
build() {
cd "$srcdir/cmake"
+ export CXXFLAGS+=" ${CPPFLAGS}"
./bootstrap --prefix=/usr \
--mandir=/share/man \
--docdir=/share/doc/cmake \
+ --datadir=/share/cmake \
--sphinx-man \
+ --sphinx-html \
--system-libs \
--qt-gui \
--parallel=$(/usr/bin/getconf _NPROCESSORS_ONLN)
@@ -51,19 +56,7 @@ package() {
cd "$srcdir/cmake"
make DESTDIR="${pkgdir}" install
- vimpath="${pkgdir}/usr/share/vim/vimfiles"
- install -d "${vimpath}"/{help,indent,syntax}
- ln -s /usr/share/cmake-${shortver}/editors/vim/indent/cmake.vim \
- "${vimpath}"/indent/
- ln -s /usr/share/cmake-${shortver}/editors/vim/syntax/cmake.vim \
- "${vimpath}"/syntax/
-
- install -d "${pkgdir}"/usr/share/emacs/site-lisp/
- emacs -batch -f batch-byte-compile \
- "${pkgdir}"/usr/share/cmake-${shortver}/editors/emacs/cmake-mode.el
- ln -s /usr/share/cmake-${shortver}/editors/emacs/cmake-mode.el \
- "${pkgdir}"/usr/share/emacs/site-lisp/
-
- install -Dm644 Copyright.txt \
- "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ rm -r "$pkgdir"/usr/share/doc/cmake/html/_sources
+ emacs -batch -f batch-byte-compile "${pkgdir}"/usr/share/emacs/site-lisp/cmake-mode.el
+ install -Dm644 Copyright.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}