summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56d86063d563
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Romain Porte <microjoe@microjoe.org>
+
+pkgname=cmaptools
+pkgver=v6.02
+_pkgdate=08-11-16
+pkgrel=1
+pkgdesc="The IHMC CmapTools for concept maps"
+arch=('x86_64')
+url="http://cmap.ihmc.us/"
+license=('unknown')
+depends=('desktop-file-utils')
+makedepends=('the_silver_searcher')
+source=(http://cmapdownload.ihmc.us/installs/CmapTools/Linux/Linux64CmapTools_$pkgver\_$_pkgdate.bin
+ installer.properties
+ icon.png
+ cmaptools.desktop
+ cmaptools)
+md5sums=('622c89d77c3a57dbe9a1a9a7a06e6dce'
+ 'a6aa32dfa1a7a5bc5e6dc585e197e002'
+ 'c37998dc8a4703de169283d49a49c40d'
+ '23f9a626c04321284930d6a79b2cf5b1'
+ 'acda9def3e84dd87066530ba187bcd1d')
+
+
+package() {
+ mkdir -p $pkgdir/opt/cmaptools
+
+ # Start installer in silent mode (see
+ # http://cmap.ihmc.us/docs/cmaptools-console-silent-installation.php for
+ # silent installation instructions)
+ chmod +x Linux64CmapTools_$pkgver\_$_pkgdate.bin
+ ./Linux64CmapTools_$pkgver\_$_pkgdate.bin \
+ -f installer.properties \
+ -DUSER_INSTALL_DIR=$pkgdir/opt/cmaptools \
+ -DUSER_SHORTCUTS=$pkgdir/usr/share/applications \
+ || true
+
+ # Remove useless symbolic links
+ rm $pkgdir/opt/cmaptools/Uninstall\ CmapTools
+ rm $pkgdir/opt/cmaptools/CmapTools
+
+ # Remove useless uninstaller
+ rm -r $pkgdir/opt/cmaptools/UninstallerData
+
+ # Copy icon
+ install -Dm644 icon.png $pkgdir/opt/cmaptools/icon.png
+
+ # Copy desktop file
+ install -Dm644 cmaptools.desktop $pkgdir/usr/local/share/applications/cmaptools.desktop
+
+ # Copy bash executable to path
+ install -Dm755 cmaptools $pkgdir/usr/local/bin/cmaptools
+
+ # Fix references to $pkgdir because installer is dumb
+ cd $pkgdir
+ ag $pkgdir -l --print0 | xargs -0 sed -i "s=$pkgdir=/opt=g"
+}
+
+post_install() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+
+