summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32727aa6e1d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: <clu@eeviac>
+
+pkgname=cmpfit
+pkgver=1.2
+pkgrel=2
+pkgdesc="A MINPACK-1 Least Squares Fitting Library in C"
+url="http://www.physics.wisc.edu/~craigm/idl/cmpfit.html"
+arch=('i686' 'x86_64')
+license=('unknown')
+depends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=(http://www.physics.wisc.edu/~craigm/idl/down/$pkgname-$pkgver.tar.gz)
+md5sums=('ea86da19015c4dd456e2a9e3655b1b4d')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # Install because makefile has no install...
+ mkdir -p $pkgdir/usr/lib
+ install -Dm644 libmpfit.a $pkgdir/usr/lib
+
+ mkdir -p $pkgdir/usr/include
+ install -Dm644 mpfit.h $pkgdir/usr/include
+}