summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7729fb7bbb70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=('cmsis-svd-git')
+pkgver=0.4
+pkgrel=1
+pkgdesc='Aggegration of ARM Cortex-M CMSIS SVDs and related tools'
+arch=('any')
+url='https://github.com/posborne/cmsis-svd'
+license=('custom')
+depends=('python')
+makedepends=('python-setuptools')
+source=('cmsis-svd::git+https://github.com/posborne/cmsis-svd')
+md5sums=('SKIP')
+
+package() {
+ cd cmsis-svd/python
+ python setup.py bdist
+ cd $pkgdir
+ tar -xzvf $srcdir/cmsis-svd/python/dist/cmsis-svd-*.tar.gz
+}