summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8064f2ee953..3f3e5d859e86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=cntk
_gitname=CNTK
-pkgver=2.5
+pkgver=2.5.1
pkgrel=1
pkgdesc="Microsoft Cognitive Toolkit (CNTK), an open source deep-learning toolkit"
arch=('x86_64')
url="https://github.com/Microsoft/$_gitname"
license=('CUSTOM')
-depends=('boost' 'cub' 'cuda' 'cudnn' 'libzip' 'nccl' 'nvidia-utils' 'openblas-lapack' 'opencv' 'openmp' 'openmpi' 'protobuf' 'python-numpy' 'python-scipy')
-makedepends=('cmake' 'git' 'inetutils' 'java-environment' 'python-pip' 'python-setuptools' 'python-wheel' 'swig' )
+depends=('gcc6' 'boost' 'cub' 'cuda' 'cudnn' 'libzip' 'nccl' 'nvidia-utils' 'openblas-lapack' 'opencv' 'openmp' 'openmpi' 'protobuf' 'python-numpy' 'python-scipy')
+makedepends=('cmake' 'git' 'inetutils' 'java-environment' 'python-pip' 'python-setuptools' 'python-wheel' 'swig')
optdepends=('swig' 'java-environment')
source=("git+$url#tag=v$pkgver")
md5sums=('SKIP')
@@ -25,7 +25,11 @@ prepare(){
# https://github.com/Microsoft/CNTK/issues/62
sed 's|/var/lock/|/tmp/cntk/|g' -i `grep '/var/lock' . -rIl`
+ # https://github.com/Microsoft/CNTK/issues/3191
+ sed '120s/.*/return cub::ShuffleIndex<CUB_PTX_WARP_THREADS>(input, srcLane, mask);/' -i Source/Math/CntkBatchNormalization.cuh
+
mkdir -p build
+ export OMPI_MPICXX=g++-6
./configure \
--with-build-top=build \
--with-jdk=/usr/lib/jvm/default \
@@ -69,5 +73,7 @@ package() {
cd $srcdir/$_gitname/build/python
pip install --root=$pkgdir ${pkgname}_gpu-$pkgver-cp36-cp36m-linux_x86_64.whl
+ rm -rf $pkgdir/usr/lib/python3.6/site-packages/$pkgname/libs
+
install -Dm644 $srcdir/$_gitname/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}