summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 798fdbf3fdfa..6f7cf1d3bc0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=coccinelle
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Provides spatch program used to apply semantic patches"
arch=('i686' 'x86_64')
url="http://coccinelle.lip6.fr/"
@@ -19,8 +19,15 @@ depends=('pcre' 'python')
optdepends=('ocaml: OCaml scripting feature'
'ocaml-findlib: OCaml scripting feature')
options=('!strip')
-source=(https://github.com/coccinelle/${pkgname}/archive/${pkgver}.tar.gz)
-sha256sums=('095919e129ac563586d880ebbc5aac829fec224177090aebe34dc34ed5f142bf')
+source=(https://github.com/coccinelle/${pkgname}/archive/${pkgver}.tar.gz
+ 0001-Fix-263-wrong-default-path-for-COCCINELLE_HOME.patch)
+sha256sums=('095919e129ac563586d880ebbc5aac829fec224177090aebe34dc34ed5f142bf'
+ '9c52674ba49f9789d1a88df54a453835aa1f4b4645a9b770d3231a05bc3b22c7')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 < "$srcdir/0001-Fix-263-wrong-default-path-for-COCCINELLE_HOME.patch"
+}
build() {
cd "$pkgname-$pkgver"