summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f65c11a766e5..07483e70920c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,35 +8,28 @@
# Contributor: Vladimir Kirillov <proger@wilab.org.ua>
pkgname=coccinelle
-pkgver=1.0.6
-pkgrel=2
+pkgver=1.0.7
+pkgrel=1
pkgdesc="Provides spatch program used to apply semantic patches"
arch=('i686' 'x86_64')
url="http://coccinelle.lip6.fr/"
license=('GPL2')
-makedepends=('camlp4' 'ocaml' 'ocaml-findlib')
+makedepends=('ocaml' 'ocaml-findlib' 'ocaml-num')
depends=('pcre' 'python')
optdepends=('ocaml: OCaml scripting feature'
'ocaml-findlib: OCaml scripting feature')
options=('!strip')
-source=(http://coccinelle.lip6.fr/distrib/${pkgname}-${pkgver}.tgz
- 0001-Fixed-compatibility-with-3.12.patch
- 0002-Added-Support-for-with-python-and-python.patch)
-sha256sums=('8452ed265c209dae99cbb33b67bc7912e72f8bca1e24f33f1a88ba3d7985e909'
- 'ddaa7263813276487ddff956bd660dcdfa25642a9a7919c431aa290b8f01b6f0'
- '7e6100c9ea3dd79868835e324e6072672dabc9a2b9ee0ba93180465f35a99d07')
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 <"$srcdir/0001-Fixed-compatibility-with-3.12.patch"
- patch -p1 <"$srcdir/0002-Added-Support-for-with-python-and-python.patch"
-}
+source=(http://coccinelle.lip6.fr/distrib/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('475e2bed5486023d19d9e0dec5e109b04b872a9917b62faf83ce3521676f728b')
build() {
cd "$pkgname-$pkgver"
./autogen
- ./configure --prefix=/usr
+ ./configure \
+ --prefix=/usr \
+ --enable-release=yes \
+ --with-python=/usr/bin/python3
make
}