summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b8d8f9f6ba5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=cod
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="A completion daemon for bash/zsh"
+arch=('any')
+url="https://github.com/dim-an/cod"
+license=('Apache-2.0')
+makedepends=('go-pie')
+optdepends=('bash-completion' 'zsh')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/dim-an/cod/archive/v$pkgver.tar.gz")
+sha256sums=('6f773358f363141dcd1bbdffaaa5dea0a40ae7a84d5fc55fd453302de8493c20')
+
+build() {
+ cd "$pkgname-$pkgver"
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}