summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94fe1c9cd863..6d17c81ca590 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,26 @@
pkgname=codegrade-fs-electron
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Electron frontend for the CodeGrade filesystem"
arch=('x86_64')
license=('AGPL3')
url="https://codegrade.com"
-depends=('python-codegrade-fs' 'c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk2' 'libappindicator-gtk3')
+depends=('python-codegrade-fs' 'gtk3' 'libxss' 'nss' 'libnotify')
makedepends=('git' 'npm' 'python')
-source=("$pkgname-$pkgver::git+https://github.com/CodeGra-de/CodeGra.fs.git#commit=50d99b53fe6043382ed514377394f73d6335191f")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver::git+https://github.com/CodeGra-de/CodeGra.fs.git#commit=50d99b53fe6043382ed514377394f73d6335191f"
+ build-pacman.patch)
+sha256sums=(
+ 'SKIP'
+ 'efcb4ecdd9e849434c42374ae5c6376a7c72a79794b51209fc8148a842c7384e')
install=codegrade-fs-electron.install
prepare() {
cd $pkgname-$pkgver
# Output Pacman archive instead of .deb
- sed -i '96s/deb/pacman/' package.json
+ patch -Np1 -i "${srcdir}/build-pacman.patch"
npm install
}