summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 23 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f386a9d66db..7df389bcd516 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,41 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgdesc='WPE launcher and webapp container'
pkgname=cog
-pkgver=0.8.0
-pkgrel=1
+pkgver=0.18.3
+pkgrel=3
url=https://github.com/Igalia/cog
arch=(i686 x86_64 aarch64 armv7l armv7h)
groups=(wpe)
conflicts=(cog-git)
-depends=('wpewebkit>=2.28.0' 'wpebackend-fdo>=1.6.0' libinput)
-makedepends=(cmake wayland-protocols)
-license=(custom:MIT)
+depends=('wpewebkit>=2.42.5-3' 'wpebackend-fdo>=1.10.0' libinput libmanette)
+makedepends=(meson wayland-protocols libxcb libxkbcommon-x11 gtk4 weston)
+optdepends=('libxcb: x11 platform support'
+ 'libxkbcommon-x11: x11 platform support'
+ 'gtk4: gtk4 platform support')
+license=(MIT)
source=("https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz"
"https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz.asc")
validpgpkeys=('5AA3BC334FD7E3369E7C77B291C559DBE4C9123B')
-md5sums=(f7aa8a425927cab247563411fc67c5a3 SKIP)
-sha1sums=(977559204dae0f9220e4c6b8ded7537899fd2daf SKIP)
-sha256sums=(181b1f4963cdf264b8068460a64d14c92a627f7138ebecc0f36fce085f4e92dd SKIP)
+md5sums=('e457de5b5ac8994ae9971c0a5a22b8a2' 'SKIP')
+sha1sums=('21df2a84c651b45e78d08e45e71631250a0078c3' 'SKIP')
+sha256sums=('cd4ec937175a290ccd7c8ec398e4569aec04084cd94b11b2d83518778ba9d055' 'SKIP')
build () {
- cmake -H"${pkgname}-${pkgver}" -Bbuild \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DCOG_PLATFORM_FDO=ON \
- -DCOG_PLATFORM_DRM=ON \
- -DCOG_BUILD_PROGRAMS=ON \
- -DINSTALL_MAN_PAGES=ON \
- -DCOG_WESTON_DIRECT_DISPLAY=OFF # Needs libweston-9-protocols
- cmake --build build
+ rm -rf _build
+ arch-meson \
+ -D documentation=false \
+ -D manpages=true \
+ -D platforms=drm,gtk4,headless,wayland,x11 \
+ -D programs=true \
+ -D wayland_weston_content_protection=true \
+ -D wayland_weston_direct_display=true \
+ -D wpe_api=2.0 \
+ _build "${pkgname}-${pkgver}"
+ meson compile -C _build
}
package () {
- DESTDIR="${pkgdir}" cmake --build build --target install
+ meson install -C _build --destdir "${pkgdir}"
install -Dm644 "${pkgname}-${pkgver}/COPYING" \
"${pkgdir}/usr/share/licenses/${pkgname}/COPYING"