summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 499178234a5a..0bd6749c9bd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgdesc='WPE launcher and webapp container'
pkgname=cog
-pkgver=0.8.1
+pkgver=0.10.0
pkgrel=1
url=https://github.com/Igalia/cog
arch=(i686 x86_64 aarch64 armv7l armv7h)
groups=(wpe)
conflicts=(cog-git)
-depends=('wpewebkit>=2.28.0' 'wpebackend-fdo>=1.6.0' libinput)
-makedepends=(cmake wayland-protocols)
+depends=('wpewebkit>=2.30.0' 'wpebackend-fdo>=1.8.0' libinput)
+makedepends=(cmake wayland-protocols libxcb libxkbcommon-x11 gtk4)
+optdepends=('libxcb: x11 platform support'
+ 'libxkbcommon-x11: x11 platform support'
+ 'gtk4: gtk4 platform support')
license=(custom:MIT)
source=("https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz"
"https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz.asc")
validpgpkeys=('5AA3BC334FD7E3369E7C77B291C559DBE4C9123B')
-md5sums=(21664fb04c9149dea6d68e13e6074276 SKIP)
-sha1sums=(baabba7f0f6009c64ef0c4f7c5f807382cffef5d SKIP)
-sha256sums=(b82e917eb764943b9859c631974f8f0e748b79ae87bb7a944f46c818740e0208 SKIP)
+md5sums=(1b0407b6163a3a01afdfc0fb454a7570 SKIP)
+sha1sums=(911816c00a2b08f4cfd388b1d2e176835c9b4e9e SKIP)
+sha256sums=(2c72369c636ca4684370adad1344071b23c9ee2c851eb7d738fa2e1d7092031f SKIP)
build () {
cmake -H"${pkgname}-${pkgver}" -Bbuild \
@@ -24,6 +27,9 @@ build () {
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCOG_PLATFORM_FDO=ON \
-DCOG_PLATFORM_DRM=ON \
+ -DCOG_PLATFORM_X11=ON \
+ -DCOG_PLATFORM_GTK4=ON \
+ -DCOG_PLATFORM_HEADLESS=ON \
-DCOG_BUILD_PROGRAMS=ON \
-DINSTALL_MAN_PAGES=ON \
-DCOG_WESTON_DIRECT_DISPLAY=OFF # Needs libweston-9-protocols