summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dea153cb0468..c41abc373302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,9 @@
# Maintainer: Samuel Balula sbalula@ethz.ch
# Intructions/ Troubleshoot
-# Download the source from http://www.hsl.rl.ac.uk/ and place it in the folder, replacing the empty placeholder file
+# Download the source from https://www.hsl.rl.ac.uk/ipopt/ and place it in the folder, replacing the empty placeholder file
# Check the sha256sum of the downloaded tarball, it may be different from the one listed here. If so either use "SKIP"
# or replace with your tarball sha256sum
-# A user has reported that "--prefix=/usr" was needed with "./configure" such that IPopt could recognize the installation. That was not the case for me.
-
pkgname=coin-or-hsl
_pkgname=coinhsl
pkgrel=1
@@ -14,7 +12,7 @@ pkgdesc="HSL Mathematical Software Library. Including solvers for sparse linear
arch=('i686' 'x86_64')
url="http://www.hsl.rl.ac.uk/"
makedepends=('gcc' 'metis' 'gcc-fortran')
-depends=()
+depends=('openblas-lapack')
optdepends=('openmp' 'coin-or-ipopt')
source=("ThirdParty-HSL::git+https://github.com/coin-or-tools/ThirdParty-HSL.git" "manual://${_pkgname}-${pkgver}.tar.gz")
sha256sums=("SKIP" "95ce1160f0b013151a3e25d40337775c760a8f3a79d801a1d190598bf4e4c0c3")
@@ -22,16 +20,14 @@ sha256sums=("SKIP" "95ce1160f0b013151a3e25d40337775c760a8f3a79d801a1d190598bf4e4
build() {
cd $srcdir/ThirdParty-HSL
ln -sf ../${_pkgname}-${pkgver} coinhsl
- ./configure
- #./configure --prefix=/usr
+ OMP_NUM_THREADS=$(nproc) ./configure --prefix=/usr LIBS="-llapack" --with-blas="-L/usr/lib -lopenblas" CXXFLAGS="-O3 -fopenmp" FCFLAGS="-O3 -fopenmp" CFLAGS="-O3 -fopenmp"
make DESTDIR=$pkgdir
}
-package ()
-{
+package () {
cd $srcdir/ThirdParty-HSL
make DESTDIR=$pkgdir install
- #For Ipopt:
- ln -rs $pkgdir/usr/local/lib/libcoinhsl.so $pkgdir/usr/local/lib/libhsl.so
-}
+ # For Ipopt:
+ ln -rs $pkgdir/usr/lib/libcoinhsl.so $pkgdir/usr/lib/libhsl.so
+}