summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ebdf9645938..0a960c8673f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=collectd
pkgver=5.12.0
-pkgrel=15
+pkgrel=16
pkgdesc='Daemon which collects system performance statistics periodically'
url='https://collectd.org/'
arch=('x86_64' 'aarch64')
@@ -61,6 +61,10 @@ build() {
cd ${pkgname}-${pkgver}
# fix nut plugin build
export CFLAGS="$CFLAGS -Wno-incompatible-pointer-types"
+ # quick fix for https://github.com/collectd/collectd/issues/4310
+ # libgcrypt-config is gone
+ export GCRYPT_CPPFLAGS="$(pkg-config libgcrypt --cflags)"
+ export GCRYPT_LIBS="$(pkg-config libgcrypt --libs)"
./configure \
--prefix=/usr \
--sysconfdir=/etc \