summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e792bd3c1e5..82ee699ff401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ name=colmap
fragment="#branch=dev"
pkgname=${name}-git
pkgver=3.6.dev.2.r13.g6af3d8b
-pkgrel=1
+pkgrel=2
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
url="https://colmap.github.io/"
@@ -22,6 +22,7 @@ fi
install=${pkgname}.install
source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
"nvm-export.patch"
+ "gcc9.patch"
"${pkgname}.install"
"vocabulary-tree-32K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words32K.bin"
"vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin"
@@ -29,6 +30,7 @@ source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
)
md5sums=('SKIP'
'1542bbbaa7951dbf0b2472354b4b493d'
+ 'cff4ef88ae7e4cb0d08265f9e6715364'
'ebb1dc43e014a1e720a06422c6248a40'
'65b200a06e15205bda713c8553953c50'
'57e1c8073d9085631911e060c3802bd2'
@@ -41,7 +43,7 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
- git apply ${srcdir}/nvm-export.patch
+ git apply ${srcdir}/*.patch
}