summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 12 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17e79bd0242b..ea1d05b34dbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,31 +5,22 @@
pkgname=combblas
_PkgName=CombBLAS
-pkgver=1.6.2+r4666
-pkgrel=2
+pkgver=2.0.0
+pkgrel=1
pkgdesc="A library offering a set of linear algebra primitives for graph analytics"
arch=('x86_64')
url="https://github.com/PASSIONLab/CombBLAS"
license=("BSD")
depends=('openmpi')
-makedepends=('cmake' 'git')
-source=("git+$url.git")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/$_PkgName"
- printf "1.6.2+r%s" "$(git rev-list --count HEAD)"
-}
-
-prepare() {
- mkdir build
-}
+makedepends=('cmake')
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('632a94201a042a2a9aa86803f50ee38b7bf0aa1cfef6ba0eb34ea4007f79a679')
build() {
- cd build
-
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
# Some tests are computationally heavy MPI stuff, so avoid them
- cmake ../$_PkgName \
+ cmake ../$_PkgName-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=ON \
-DBUILD_TESTING=OFF
@@ -37,19 +28,19 @@ build() {
}
package() {
- cd build
+ cd "$srcdir/build"
make DESTDIR="$pkgdir" install
# Remove OS X leftover files
find "$pkgdir" -name "*.DS_Store" -delete
find "$pkgdir" -name "._*" -delete
- install -Dm644 "$srcdir/$_PkgName/LICENSE" \
+ install -Dm644 ../$_PkgName-$pkgver/LICENSE \
-t "$pkgdir/usr/share/licenses/$pkgname"
# Add extra headers
- install -Dm644 "$srcdir/$_PkgName"/Applications/*.h \
+ install -Dm644 ../$_PkgName-$pkgver/Applications/*.h \
-t "$pkgdir/usr/include/CombBLAS/Applications"
- install -Dm644 "$srcdir/$_PkgName"/Applications/BipartiteMatchings/*.h \
+ install -Dm644 ../$_PkgName-$pkgver/Applications/BipartiteMatchings/*.h \
-t "$pkgdir/usr/include/CombBLAS/Applications/BipartiteMatchings"
}