summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d90f89e9912
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
+
+pkgname=comictagger
+_srctag=1.3.0-alpha.0
+pkgver=${_srctag//-/.}
+pkgrel=1
+pkgdesc='Application for writing metadata to digital comics, written in Python and PyQt'
+arch=(any)
+url='https://github.com/comictagger/comictagger'
+license=(Apache)
+makedepends=('python-setuptools')
+depends=('python'
+ 'python-beautifulsoup4'
+ 'python-natsort'
+ 'python-pypdf2'
+ 'python-pillow'
+ 'python-pyqt5'
+ 'python-unrar-cffi')
+source=(git+https://github.com/comictagger/comictagger.git#tag=$_srctag)
+sha256sums=('SKIP')
+
+build() {
+ cd comictagger
+ python setup.py build
+}
+
+package() {
+ cd comictagger
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}