summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 20 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac038af18387..d5587816429d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,34 @@
-# Maintainer: Justin Dray <justin@dray.be>
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
# Contributor: Matthias Maennich <arch@maennich.net>
+
pkgname=command-not-found
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="In case a command could not be found this utility searches for packages containing this or a similar command (bash,zsh)."
arch=('i686' 'x86_64')
-url="http://github.com/metti/command-not-found"
+url="http://github.com/metti/$pkgname"
license=('GPL')
-depends=('boost-libs' 'tdb' 'libarchive' 'wget')
-makedepends=('boost' 'tdb' 'cmake' 'git')
-md5sums=('3f7f705dc151b33742e888bcef17b58b')
-install='command-not-found.install'
-source=("https://github.com/metti/command-not-found/archive/v${pkgver}.zip")
+depends=('boost-libs'
+ 'libarchive'
+ 'tdb'
+ 'wget')
+makedepends=('boost'
+ 'cmake'
+ 'git')
+md5sums=('e991b83a0f0a65b4180683cd04c845e5')
+install=$pkgname.install
+source=("$url/archive/v$pkgver.zip")
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- cmake -D CMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="" src
+ cd $pkgname-$pkgver
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="" \
+ src
make
}
package(){
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
}