summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b5b609d0fbc..358b0d41e16e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Lukas1818 aur at lukas1818 dot de
pkgname=commander-wars
-pkgver=0.25.5
-_pkgtag="Beta_25_5"
+pkgver=0.28.2
+_pkgtag="Beta28_Build2"
pkgrel=1
pkgdesc="Advance Wars Clone with a lot of additions customizations and modding support"
arch=("$CARCH")
@@ -11,12 +11,15 @@ license=('LGPL3')
options=(!emptydirs)
depends=('qt6-declarative' 'qt6-multimedia')
makedepends=('ninja' 'qt6-tools')
-source=("https://github.com/Robosturm/Commander_Wars/archive/$_pkgtag.tar.gz")
-sha512sums=('394b2735460a48f7290935e3f526e165791fa54a7b396c816e3632f059388d577fd91747764c865f95902d3c51149bb35ecfa3c16b665198e51dd3265f51654d')
+source=("https://github.com/Robosturm/Commander_Wars/archive/$_pkgtag.tar.gz"
+ '0001-fix-QStandardPaths-include.patch')
+sha512sums=('56eba5f3de984a4912f0984f067a8daf9107b48c74162918c42024fd14c871da91d529663d7d6c65d197173750368b72ad1b2c1b77bd47c76dcf2cd2a6db1fe6'
+ '2de911786944e44a18f524508827805992a02a6890638a0e24bfcbac02374df90e8334376973263492ea04454b9ac368e71d3aa91d4b7b33a0bbc5af661bfcc2')
prepare()
{
cd "$srcdir/Commander_Wars-$_pkgtag"
+ patch -N -p1 -i "$srcdir/0001-fix-QStandardPaths-include.patch"
sed -i "0,/project (Commander_Wars/s/project (Commander_Wars /project ($pkgname /g" CMakeLists.txt #keep using old save files
sed -i "s/commander_wars/$pkgname/g" Commander_Wars.desktop
sed -i '/RPATH/d' CMakeLists.txt #remove insecure RPATH '/../'