summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5190a64b159..170a68c71b11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=commander-wars
pkgver=0.22.5.2
_pkgtag="22_5_v2"
_pkgtag="Beta_${_pkgtag//./_}"
-pkgrel=2
+pkgrel=3
epoch=0
pkgdesc="Advance Wars Clone with a lot of additions customizations and modding support"
arch=("$CARCH")
@@ -21,6 +21,7 @@ prepare()
cd "$srcdir/Commander_Wars-$_pkgtag"
sed -i "0,/project (Commander_Wars/s/project (Commander_Wars /project ($pkgname /g" CMakeLists.txt #keep using old save files
sed -i "s/commander_wars/$pkgname/g" Commander_Wars.desktop
+ sed -i '/RPATH/d' CMakeLists.txt #remove insecure RPATH '/../'
mkdir -p build
}
@@ -44,5 +45,5 @@ package()
DESTDIR="$pkgdir" samu install
echo "remove qt libs"
- rm -rf "$pkgdir/usr/lib" #do not need qt libarys, if the qt packeg is installed; addr2line is not used on linux
+ rm -rf "$pkgdir/usr/lib" #qt libarys are not needed, if the qt package is installed; addr2line binary is not used on linux
}