summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74cb5d079cf4..c10d96fe6bf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
pkgname=commander-wars
pkgver=0.25.1
_pkgtag="Beta_25_1"
-pkgrel=4
-epoch=0
+pkgrel=1
pkgdesc="Advance Wars Clone with a lot of additions customizations and modding support"
arch=("$CARCH")
url="https://github.com/Robosturm/Commander_Wars"
license=('LGPL3')
options=(!emptydirs)
-depends=('qt6-base' 'qt6-multimedia' 'qt6-wayland')
-makedepends=('samurai' 'qt6-tools')
+depends=('qt6-declarative' 'qt6-multimedia')
+makedepends=('ninja' 'qt6-tools')
source=("https://github.com/Robosturm/Commander_Wars/archive/$_pkgtag.tar.gz")
sha512sums=('297a2bfc6081fd2513df26b3855f1fa7afe2c8bc89742d144842711b73d769dc4b3ca52616fbc3dcf20c7b133429e715715fdeddcf4a50dcfd4c816b7633385c')
@@ -33,16 +32,17 @@ build()
-G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DUSEAPPCONFIGPATH=ON
+ -DUSEAPPCONFIGPATH=ON \
+ -DOPENSSL_USE_STATIC_LIBS=OFF
- samu
+ ninja
}
package()
{
cd "$srcdir/Commander_Wars-$_pkgtag/build"
- DESTDIR="$pkgdir" samu install
+ DESTDIR="$pkgdir" ninja install
echo "remove qt libs"
rm -rf "$pkgdir/usr/lib" #qt libarys are not needed, if the qt package is installed; addr2line binary is not used on linux
}