summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 511869995262..afc5c05f27a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Bertrand Bonnefoy-Claudet <bertrandbc@gmail.com>
+# Contributor: Timothy Lee <timothy.ty.lee@gmail.com>
pkgname=connman-ui-git
-pkgver=r33.1e1fd69
+pkgver=r38.fce0af9
pkgrel=1
pkgdesc="A full-featured GTK based trayicon UI for ConnMan (git version)"
arch=('i686' 'x86_64')
@@ -9,8 +10,10 @@ url="https://github.com/tbursztyka/connman-ui"
license=('GPL2')
depends=('connman' 'gtk3')
makedepends=('git' 'intltool')
-source=("git+https://github.com/tbursztyka/connman-ui.git")
-md5sums=('SKIP')
+source=('git+https://github.com/tbursztyka/connman-ui.git'
+ 'connman-ui-autostart.desktop')
+sha256sums=('SKIP'
+ 'b249cd6d59cb8814ff1d9445efe1bdbc99d164daebe0f693dda938874736a3f8')
_gitroot="connman-ui"
@@ -29,4 +32,8 @@ build() {
package() {
cd "$srcdir/$_gitroot"
make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -D -m 644 "$startdir/connman-ui-autostart.desktop" \
+ "$pkgdir/etc/xdg/autostart/connman-ui-autostart.desktop"
+ install -D -m 644 "$pkgdir/usr/share/connman_ui_gtk/icons/gsm-3g-full.png" \
+ "$pkgdir/usr/share/icons/hicolor/64x64/apps/connman-ui.png"
}