summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6f9c577af04..4e67855d7fea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=context
pkgname=${_pkgname}-modules
pkgver=2022.08.25_19.21
-pkgrel=1
+pkgrel=2
pkgdesc='ConTeXt LMTX with all ConTeXt Garden modules'
arch=('x86_64')
url="https://wiki.contextgarden.net/Installation"
@@ -11,7 +11,7 @@ license=(GPL)
depends=()
replaces=()
provides=(${_pkgname} ${_pkgname}-lmtx)
-conflicts=()
+conflicts=(${_pkgname})
optdepends=()
source=("http://lmtx.pragma-ade.nl/install-lmtx/context-linux-64.zip")
sha256sums=(SKIP)
@@ -20,12 +20,8 @@ prepare() {
cd "${srcdir}"
# https://wiki.contextgarden.net/Modules#ConTeXt_LMTX
- # Synchronize all modules from the ConTeXt Garden in the directory 'modules' which is created if it doesn't exist.
- rsync -rltv --del rsync://contextgarden.net/minimals/current/modules/ modules
- # Create the union of all modules in tex/texmf-modules (the directory is created if it doesn't exist).
- # If you have personal modules in tex/texmf-modules, they won't be modified.
- mkdir -p tex
- rsync -rlt --exclude=/VERSION --del modules/*/ tex/texmf-modules
+ # Synchronize all modules from the ConTeXt Garden in the directory 'modules'
+ rsync --recursive --links --times --info=progress2,remove,symsafe,flist,del --human-readable --del rsync://contextgarden.net/minimals/current/modules/ modules
chmod +x install.sh
./install.sh
@@ -37,6 +33,8 @@ package() {
install -d "$context"
cp -r texmf texmf-context "$context"
+ # Create the union of all modules in tex/texmf-modules.
+ rsync -rlt --exclude=/VERSION --del ../modules/*/ "$context"/texmf-modules
install -Dt "${pkgdir}/usr/local/bin" texmf-linux-64/bin/*
}