summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7cd5b4da83a3..4478a8b1c4be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=continuous-testing
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="A continuous integration testing project"
provides=("again")
arch=('any')
@@ -12,8 +12,14 @@ depends=('packer' 'libnotify' 'curl' 'fuse-overlayfs' 'less' 'rustup' 'fd' 'git'
source=("${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('797d1c07fa0b1d5ab2e48a32c83ead15f80ceeabb1b2f3e52ffe1711037b3166')
+build() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --all-features
+}
+
package() {
cd "${pkgname}-${pkgver}"
- cargo build --release
- cargo install --path .
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
}