summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8af30f6ba0ea..fdefcf6a8625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,34 @@
# Maintainer: Dan Johansen <strit@manjaro.org>
pkgname=corestuff
-pkgver=2.8.0
+pkgver=2.9.0
pkgrel=1
pkgdesc="An activity viewer from the CoreApps family."
arch=('x86_64' 'aarch64')
url="https://gitlab.com/cubocore/$pkgname"
license=('GPL3')
-depends=('qt5-base' 'qt5-x11extras' 'libcsys>=2.7.1' 'libcprime>=2.7.1' 'libxcomposite')
+depends=('qt5-base' 'qt5-x11extras' 'kglobalaccel' 'libcsys>=2.7.1' 'libcprime>=2.7.1')
+makedepends=('git')
replaces=('corebox')
groups=('coreapps')
-source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-md5sums=('9e7bf18cc80e4aa65a176407859b0b97')
+source=( #"https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+ "git+https://gitlab.com/cubocore/$pkgname.git#tag=v2.9.0")
+md5sums=('SKIP')
prepare() {
mkdir -p build
+ cd ${pkgname}
+ git submodule update --init --recursive
}
build() {
- cd ${pkgname}-v${pkgver}
+ cd ${pkgname}
qmake-qt5 ${pkgname}.pro
make
}
package() {
- cd ${pkgname}-v${pkgver}
+ cd ${pkgname}
make INSTALL_ROOT=${pkgdir} install
}