summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33e9459d99db..55b0d5036502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,27 @@
-# Contributor: Shaber
# Maintainer: Dan Johansen <strit@manjaro.org>
+# Contributor: Shaber
pkgname=corestuff
-pkgver=3.0.1
+pkgver=4.0.0
pkgrel=1
pkgdesc="An activity viewer from the CoreApps family."
arch=('x86_64' 'aarch64')
url="https://gitlab.com/cubocore/$pkgname"
license=('GPL3')
depends=('qt5-base' 'qt5-x11extras' 'libxcomposite' 'kglobalaccel' 'libcsys>=2.7.1' 'libcprime>=2.7.1')
-makedepends=('git')
replaces=('corebox')
groups=('coreapps')
-source=( #"https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
- "git+https://gitlab.com/cubocore/$pkgname.git#tag=v$pkgver")
-md5sums=('SKIP')
-
-prepare() {
- mkdir -p build
- cd ${pkgname}
- git submodule update --init --recursive
-}
+source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('39038ab6435fabaf276107df5254ca36')
build() {
- cd ${pkgname}
+ cd ${pkgname}-v${pkgver}
qmake-qt5 ${pkgname}.pro
make
}
package() {
- cd ${pkgname}
+ cd ${pkgname}-v${pkgver}
make INSTALL_ROOT=${pkgdir} install
}