summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a09f9f963f1..e9ae697a5168 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=coreutils-selinux
pkgver=8.22
-pkgrel=3
+pkgrel=4
pkgdesc="The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support"
arch=('i686' 'x86_64')
license=('GPL3')
@@ -22,17 +22,20 @@ provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
source=(ftp://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz{,.sig}
'coreutils-8.22-shuf-segfault.patch'
+ '0001-cp-don-t-reserve-a-device-number.patch'
'0001-copy-fix-SELinux-context-preservation-for-existing-d.patch'
'0002-copy-fix-a-segfault-in-SELinux-context-copying-code.patch')
md5sums=('8fb0ae2267aa6e728958adc38f8163a2'
'SKIP'
'94f7e6f373f37beb236caabed8fcdb52'
+ 'ac3825f60b6e0300e375f656a3667c52'
'a320632626e1639643f3510ae1c62ed0'
'40575ec80e895b5db52dafa6556e6e26')
prepare() {
cd ${pkgname/-selinux}-$pkgver
- patch -Np1 -i ../coreutils-8.22-shuf-segfault.patch
+ patch -p1 -i ../coreutils-8.22-shuf-segfault.patch
+ patch -p1 -i ../0001-cp-don-t-reserve-a-device-number.patch
patch -Np1 -i ../0001-copy-fix-SELinux-context-preservation-for-existing-d.patch
patch -Np1 -i ../0002-copy-fix-a-segfault-in-SELinux-context-copying-code.patch
}