aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 6 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d8e23cf6bb1..ebbc54019da1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,22 @@
# Maintainer: Stefan Göbel <aur —at— subtype —dot— de>
pkgname='corky'
-_reponame='Corky'
-pkgver='2017033001'
-pkgrel='2'
+pkgver='2019021402'
+pkgrel='1'
pkgdesc='Some Lua modules for the system monitor Conky.'
-url='https://gitlab.com/goeb/Corky/'
+url='https://gitlab.com/goeb/corky/'
install="$pkgname.install"
arch=('any')
license=('GPL3')
depends=('conky-cairo' 'lua-lpeg')
-makedepends=('git')
-source=("$pkgname::git+https://gitlab.com/goeb/$_reponame.git#tag=$pkgver")
+makedepends=('git' 'ldoc')
+source=("$pkgname::git+https://gitlab.com/goeb/$pkgname.git#tag=$pkgver")
sha256sums=('SKIP')
-prepare() {
-
- cd "$pkgname"
-
- # Change the module's path in the example configuration:
- sed -i 's!"lua/corky.lua"!"/usr/share/lua/5.3/corky.lua"!' 'example/conky.conf'
-
-}
-
package() {
cd "$pkgname"
-
- # Install the modules:
- install -dm 0755 "${pkgdir}/usr/share/lua/5.3"
- cp -a lua/* "${pkgdir}/usr/share/lua/5.3"
-
- # Install the README file and the example:
- install -dm 0755 "${pkgdir}/usr/share/doc/corky"
- cp -a README "${pkgdir}/usr/share/doc/corky"
- cp -a example "${pkgdir}/usr/share/doc/corky"
+ make install DESTDIR="$pkgdir" PREFIX='/usr'
}