summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79ffc2533d2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jeidnx <jeidnx@domainhier.de>
+
+pkgname=coshr-git
+pkgver=r1.b2103b7
+pkgrel=1
+pkgdesc="Easily share the output of your commands"
+arch=("any")
+url="https://github.com/Jeidnx/coshr"
+license=('GPL')
+depends=('wl-clipboard' 'bash')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/Jeidnx/coshr')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p "$pkdir/usr/bin/"
+ install -Dm755 "$srcdir/${pkgname%-git}/coshr.sh" "$pkgdir/usr/bin/coshr"
+}