summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2abcf8931a61..70fb8eb79b71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,7 @@ depends=(
makedepends=(
'cargo'
'git'
+ 'mold'
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -38,7 +39,12 @@ build() {
cd "${pkgname%-git}"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
- make prefix='/usr' VENDOR='1' all
+
+ # use mold instead of lld to speed up build
+ RUSTFLAGS="-C link-arg=-fuse-ld=mold"
+
+ # use nice to build with lower priority
+ nice make prefix='/usr' VENDOR='1' all
}
package() {