summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 13 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4756ffe46a10..3c8c4b891e0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,58 +5,29 @@
# Committer: Manolis Tzanidakis <manolis@archlinux.org>
pkgname=courier-imap
-pkgver=5.0.7
+pkgver=5.2.5
pkgrel=1
pkgdesc="IMAP(s)/POP3(s) Server"
arch=('i686' 'x86_64' 'armv7h')
-license=('GPL2')
-url="http://www.courier-mta.org/imap/"
-depends=('courier-maildrop' 'gcc-libs' 'gamin' 'gdbm' 'openssl' 'courier-unicode>=2.1' 'courier-authlib>=0.69.0')
+license=('GPL3')
+url="https://www.courier-mta.org/imap/"
+depends=('courier-maildrop' 'gcc-libs' 'gamin' 'gdbm' 'openssl' 'courier-unicode>=2.1' 'courier-authlib>=0.71.0')
backup=('etc/courier-imap/imapd.cnf' 'etc/courier-imap/pop3d.cnf' \
'etc/courier-imap/imapd' 'etc/courier-imap/imapd-ssl' \
'etc/courier-imap/pop3d' 'etc/courier-imap/pop3d-ssl')
conflicts=('courier-mta')
provides=('imap-server' 'pop3-server')
options=('!libtool' '!staticlibs')
-source=(http://downloads.sourceforge.net/project/courier/imap/${pkgver}/${pkgname}-${pkgver}.tar.bz2
+source=(https://downloads.sourceforge.net/project/courier/imap/${pkgver}/${pkgname}-${pkgver}.tar.bz2
courier-imapd-ssl.service
courier-imapd.service
courier-pop3d.service
courier-pop3d-ssl.service)
-sha512sums=('a0be5cb3e6bc42f4bf45b14132e7d4ad7e822c26aa3b3dd4bfefa7783a047b9c928ad503b462c8e832fddefb356af58b4adfa5ee91481bd024149992157a1aad'
- 'dfb4caa92e5033fbd5396df2e1718ae1f18d63d41f61e14014edee31f823d0fe49a151af570546767a7bafa31e0517717c1aef82896ff6741696a35bba397925'
- '7cd18dc9449255ab7fc945ceb836e470afcfa2e722bd20c19d46a88082eee61d9136a4cbccc082625ba1f0c97d70c287d2b98718694613c32a180decce5f3051'
- '419014a8956bb82de36f29afe859b6b2b57818fc7456a734c3447b389ff606c2bfe400506a2c33d4cec005583081e4cb78c38230d126aadc1f62b9ce0ec1e4d0'
- '896af7b284e48f1b85f7d485b3ca169b2b5b90f8678018a1473fe18b4852f149623c2883614d5aa8205f1a3debe910b5cbf18904adb4985bb72059704f9ebec1')
-
-prepare() {
-while [ "$option" != 2 ]
-do
-echo "**************************************************************************"
-echo "This message is only meant to make sure you've read the instructions in"
-echo "INSTALL file about updating from earlier versions; specifically the need"
-echo "to convert any existing maildirs to a Unicode naming scheme manually using"
-echo "maildirmake, more info in http://www.courier-mta.org/maildirmake.html."
-echo "**************************************************************************"
-echo ""
-echo "Choose an option:"
-echo ""
-echo "1) Install package anyway"
-echo "2) Abort"
-echo ""
-read -rp "Choose an option [1 - 2] " option
-case $option in
-1)
-break;;
-2)
-exit 0;;
-*)
-echo "'$option' I don't recognize this option."
-echo "Press enter to continue..."
-read -r;;
-esac
-done
-}
+sha512sums=('f7864bc7c23ee08ab8c90b3d83e577c62c468f96b2481e909dc0eb5aab6c6ef141e164742458776dd1106e50d8752e6e8102971a4e3d75d6a108dd72fcae0de4'
+ '3a5334b38dcae3f4caeaef0819debe6c13ead992dafb224eef7bdaee6d1c8c1faa4fb995ec79aeb71abf5ea03f05eb6d1981386b2b90058ba6fd0c2c82c34f04'
+ 'f293231a59f92ffb2e1835b56216ec6658cb48c97f5d2701be4d809600ee6f49f0a2678f9156f084e097d9fab8bd8de53acb9862457da313afcbf06326d75dcb'
+ '20d8bab38bbb00023437c9384894471649e75b10bbcf7d3a7b3923b6453af96421c494bc5f7f83f5463a266d0d14dfb0ba0e08b01ea3e4deac24f40f5e986b2f'
+ 'f1bd578c7fa8af060252aea84dacbe629cf6f76895c0499d84b26e17526965d9b27584b8c0240670fd0294506ac426c99f6af1d1e1c062a82e420105b65d7433')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -78,7 +49,7 @@ build() {
--with-trashquota \
--with-db=gdbm \
--with-mailuser=courier --with-mailgroup=courier \
- --with-notice=unicode
+ --with-notice=unicode --build=x86_64
make
}
@@ -88,8 +59,9 @@ package() {
make DESTDIR="${pkgdir}" install
# cleanup - provided by courier-maildrop
- rm "${pkgdir}/usr/bin/"{deliverquota,maildirmake,makedat}
+ rm "${pkgdir}/usr/bin/"{deliverquota,maildirmake,makedat,maildirkw}
rm "${pkgdir}/usr/share/man/man1/"maildirmake*
+ rm "${pkgdir}/usr/share/man/man1/"maildirkw*
rm "${pkgdir}/usr/share/man/man8/"deliverquota*
###############################################################################
# this is what usually "make install-configure" does