summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0af7eefb46d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+_pkgname="cover-thumbnailer"
+pkgname="${_pkgname}-git"
+pkgver=760a344
+pkgrel=1
+pkgdesc="Generates thumbnails for Nautilus folders (music album covers,...)."
+arch=('i686' 'x86_64')
+url="https://github.com/flozz/cover-thumbnailer"
+license=('GPL3')
+depends=('python2-pillow' 'python2-gconf')
+makedepends=('gettext')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/flozz/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --always | sed 's|-|.|g' | sed 's|_|.|g' | cut -d'.' -f2-
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ ./install.sh -p ${pkgdir}
+}
+
+# vim:set ts=4 sw=2 ft=sh et: