summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beefe697719f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Julian Gwywitz <aur@geigi.de>+
+
+pkgname=cozy-audiobooks
+_gitname=cozy
+pkgdesc=' A modern audio book player for Linux using GTK+ 3.'
+pkgver=0.2.2
+pkgrel=1
+url='https://github.com/geigi/cozy'
+arch=('i686' 'x86_64')
+license=('GPL3')
+makedepends=('meson' 'ninja')
+depends=(
+ 'appstream-glib' 'desktop-file-utils' 'gobject-introspection' 'gst-python'
+ 'gstreamer' 'gtk3' 'python-dbus' 'python-gobject' 'python-mutagen'
+)
+conflicts=("${_gitname}")
+provides=("${_gitname}")
+source=(
+ "https://github.com/geigi/cozy/archive/${pkgver}.zip"
+
+)
+sha256sums=(
+ 'SKIP'
+)
+
+build() {
+ cd "cozy-${pkgver}"
+ meson \
+ --buildtype='release' \
+ --prefix='/usr' \
+ build
+ ninja -C build
+}
+
+package() {
+ cd "cozy-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+} \ No newline at end of file