summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 793911844dcd..cf50e08665b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=cpeditor-git
_pkgname=cpeditor
-pkgver=6.11.1.r14.g5ef969df
+pkgver=6.11.1.r15.g79bcba11
pkgrel=1
pkgdesc='The editor for competitive programming'
arch=('x86_64')
url='https://github.com/cpeditor/cpeditor'
license=('GPL3')
-depends=('qt5-base' 'hicolor-icon-theme')
+depends=('qt5-base' 'syntax-highlighting' 'hicolor-icon-theme')
makedepends=(
"cmake"
"git"
@@ -28,14 +28,13 @@ provides=('cpeditor')
conflicts=("cpeditor")
source=('git+https://github.com/cpeditor/cpeditor.git'
- 'git+https://github.com/cpeditor/QCodeEditor.git'
'git+https://github.com/cpeditor/QtFindReplaceDialog.git'
'git+https://github.com/cpeditor/lsp-cpp.git'
'git+https://github.com/itay-grudev/singleapplication.git'
'git+https://github.com/MikeMirzayanov/testlib.git'
'git+https://github.com/cpeditor/qhttp.git')
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$_pkgname"
@@ -46,7 +45,6 @@ prepare() {
cd "$_pkgname"
git submodule init
- git config submodule.third_party/QCodeEditor.url "$srcdir/QCodeEditor"
git config submodule.third_party/QtFindReplaceDialog.url "$srcdir/QtFindReplaceDialog"
git config submodule.third_party/lsp-cpp.url "$srcdir/lsp-cpp"
git config submodule.third_party/singleapplication.url "$srcdir/singleapplication"