summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f3fa52f862b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ranieri Althoff <ranisalt+aur at gmail dot com>
+
+pkgname=cppinclude
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='Tool for analyzing includes in C++'
+url='https://github.com/cppinclude/cppinclude'
+license=('MIT')
+arch=('x86_64')
+depends=('gcc-libs')
+makedepends=('meson' 'python-mako' 'glslang' 'libglvnd' 'lib32-libglvnd'
+ 'vulkan-headers' 'vulkan-icd-loader' 'lib32-vulkan-icd-loader'
+ 'libxnvctrl' 'dbus')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('31c36a347b43ee667c6f17121c2d0fb7cf4d2672130f25273a48835b21f6ae40')
+
+build() {
+ cmake "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ install -Dm755 -t "$pkgdir/usr/bin" cppinclude
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" "$pkgname-$pkgver/LICENSE"
+}