summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff20f4c96a53..041bb248f63d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess DOT mn>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
# Contributor: Bruno Pagani <archange@archlinux.org>
pkgname=cppo
pkgver=1.6.6
-pkgrel=1
+pkgrel=2
pkgdesc="C-style preprocessor for OCaml"
arch=('x86_64')
url="https://github.com/ocaml-community/cppo"
@@ -11,13 +12,14 @@ license=('BSD')
depends=('glibc')
optdepends=('ocamlbuild: ocamlbuild plugin')
makedepends=('dune' 'ocamlbuild')
+changelog=Changes
source=("https://github.com/ocaml-community/cppo/releases/download/v${pkgver}/${pkgname}-v${pkgver}.tbz")
sha512sums=('44ecf9d225d9e45490a2feac0bde04865ca398dba6c3579e3370fcd1ea255707b8883590852af8b2df87123801062b9f3acce2455c092deabf431f9c4fb8d8eb')
build() {
cd "${srcdir}/${pkgname}-v${pkgver}"
- dune build
+ dune build --profile release
}
check() {
@@ -28,8 +30,8 @@ check() {
package() {
cd "${srcdir}/${pkgname}-v${pkgver}"
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
- dune install --destdir="${pkgdir}"
install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}