summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07eedf8c631c..fa4723f8b990 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: vagnum08 <vagnum08@gmail.com>
pkgname=cpupower-gui
-pkgver=0.6.2
-pkgrel=3
+pkgver=0.7.0
+pkgrel=1
pkgdesc="A GUI utility to set CPU frequency limits"
arch=(any)
url="https://gitlab.com/vagnum08/cpupower-gui"
@@ -13,22 +13,15 @@ optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
makedepends=('autoconf-archive')
provides=("${pkgname}")
conflicts=("${pkgname}")
-_upload_id=211f0fdb09c1e3fed1a2465484137d0d
-source=("${pkgname}_${pkgver}.orig.tar.xz"::"https://gitlab.com/vagnum08/cpupower-gui/uploads/${_upload_id}/${pkgname}-${pkgver}.tar.xz")
-
-sha256sums=('b4a852415f60002415692ff202e682d323664cbf424c426add3d3ce068ac0243')
+source=("${pkgname}_${pkgver}.orig.tar.gz"::"https://github.com/vagnum08/cpupower-gui/archive/v${pkgver}.tar.gz")
+sha256sums=('8fd21c60bd6ea75f2a9b26a72ac6711465ba10c5461788cbdbde89b82e280e99')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
- ./configure --prefix=/usr
+ ./autogen.sh --prefix=/usr
make
}
-check() {
- cd "$srcdir/${pkgname}-${pkgver}"
- make -k check
-}
-
package() {
cd "$srcdir/${pkgname}-${pkgver}"
make DESTDIR="$pkgdir/" install