summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 10 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6a2f0095aec..45e01d5f48e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,17 @@
pkgname=cquery-git
_pkgname=cquery
-pkgver=791.ebad9e2
+pkgver=826.6c1126a
pkgrel=1
pkgdesc='Low-latency vscode language server for large C++ code-bases, powered by libclang.'
arch=('any')
url='https://github.com/jacobdufault/cquery/'
license=('MIT')
-depends=('clang' 'libtinfo5')
-makedepends=("git" "python2")
-source=('git+https://github.com/jacobdufault/cquery.git' 'cquery-sh')
+depends=('clang')
+makedepends=("git" "python")
+source=('git+https://github.com/jacobdufault/cquery.git')
md5sums=(
'SKIP'
- 'cdefbd32658ab9c6a531deb64c512c5d'
)
pkgver() {
@@ -25,31 +24,20 @@ prepare() {
cd $_pkgname
git submodule update --init --recursive
sed -e "s/, '-Werror'//g" -i ./wscript
- sed -e "s/rpath=.*,/rpath=\['lib'\],/g" -i ./wscript
}
build() {
cd $_pkgname
- python2 waf configure
- python2 waf build
- cd build
- ls -l lib || ln -s clang+llvm*/lib lib
+ python waf configure --prefix="$pkgdir/usr" --use-system-clang
+ python waf build
}
check() {
- cd $_pkgname/build
- ln -sf ../tests tests
- yes | ./app --test-unit --test-index --clang-sanity-check
+ cd $_pkgname
+ yes | build/release/bin/cquery --test-unit --test-index --clang-sanity-check
}
package() {
- install -m 755 -d "${pkgdir}/opt/cquery/"
- cd $_pkgname/
- cp -rf ./clang_resource_dir ${pkgdir}/opt/cquery/
- cd build/
- install -m 755 ./app "${pkgdir}/opt/cquery/cquery"
- install -m 755 -d "${pkgdir}/opt/cquery/lib"
- install -m 755 -t "${pkgdir}/opt/cquery/lib" lib/*.so*
- install -m 755 -d "${pkgdir}/usr/bin"
- install -D -m 755 "${srcdir}/cquery-sh" "${pkgdir}/usr/bin/cquery"
+ cd $_pkgname
+ python waf install
}