summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d20909148163..9bd8ace4c652 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,8 +37,7 @@ pkgver() {
build() {
cd "craftos2"
make -C craftos2-lua linux
- ./configure --prefix=/usr/local
- sed -r -e 's/(CPPFLAGS=.*)/\1 -DCRAFTOSPC_COMMIT=\\"$(shell git rev-parse --short HEAD)\\"/' Makefile > Makefile
+ CPPFLAGS='-DCRAFTOSPC_COMMIT=\\"$(shell git rev-parse --short HEAD)\\"' ./configure --prefix=/usr/local
make
}