summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79c3b874bbc2..449c3729ba16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,43 @@
# Maintainer: Quint Guvernator <quint@guvernator.net>
-pkgname="creddit-git"
+_pkgname=creddit
+pkgname=creddit-git
pkgver=r214.aa129b9c9b2a
-pkgrel=1
+pkgrel=2
pkgdesc='CLI Reddit client written in C.'
arch=('x86_64' 'i686')
url='https://github.com/Cotix/cReddit'
license=('MIT')
depends=('ncurses' 'curl')
makedepends=('git')
-provides=("$pkgname")
-conflicts=("$pkgname")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
source=(
- "$pkgname::git+https://github.com/Cotix/cReddit.git"
+ "$_pkgname::git+https://github.com/Cotix/cReddit.git"
'01-ncursesw-is-default-ncurses.patch'
)
md5sums=('SKIP'
- '9b475cc98d0319356772d8472b602c67')
+ 'f61218a4235e342f7b094d8aac189683')
prepare() {
+ cd "$_pkgname"
+
# patch the location of the ncursesw library
patch -p1 -i "$srcdir/01-ncursesw-is-default-ncurses.patch"
}
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$pkgname"
+ cd "$_pkgname"
make
}
package() {
- cd "$pkgname"
+ cd "$_pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
make PREFIX="$pkgdir/usr/" install
}