summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 120cf87a9d4b..a773652386da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Tavian Barnes <tavianator@tavianator.com>
pkgname=creduce
-pkgver=2.8.0
-_commit=8ad1b4021a1d46f9b448d7c1b9fb01aca4a35b55
+pkgver=2.10.0
+#_commit=fb91843c547794f165e5764a003166191e6c6643
pkgrel=1
epoch=
pkgdesc="A C/C++ program reducer"
arch=('i686' 'x86_64')
url="https://embed.cs.utah.edu/creduce/"
license=('custom:University of Illinois Open Source License')
-depends=('astyle' 'clang>=5.0.0' 'indent' 'llvm>=5.0.0'
+depends=('astyle' 'clang>=8.0.0' 'indent' 'llvm>=8.0.0'
'perl-benchmark-timer' 'perl-exporter-lite' 'perl-file-which'
'perl-getopt-tabular' 'perl-regexp-common' 'perl-sys-cpu')
-#source=("https://embed.cs.utah.edu/$pkgname/$pkgname-$pkgver.tar.gz")
-source=("$pkgname-$_commit.tar.gz::https://github.com/csmith-project/creduce/archive/$_commit.tar.gz")
-md5sums=('faa788c48960804fbc75e2b150b05513')
-sha256sums=('e2dd8a3c5e86199ab6fef832ff728dde7affaa7c32fce8c341a229080bb256b5')
+source=("https://embed.cs.utah.edu/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('ec9d5fd3c71840c7361cdf626fe1f202')
+sha256sums=('db1c0f123967f24d620b040cebd53001bf3dcf03e400f78556a2ff2e11fea063')
+#source=("$pkgname-$_commit.tar.gz::https://github.com/csmith-project/creduce/archive/$_commit.tar.gz")
build() {
- cd "$pkgname-$_commit"
+ cd "$pkgname-$pkgver"
./configure --prefix=/usr
make
}
package() {
- cd "$pkgname-$_commit"
+ cd "$pkgname-$pkgver"
make install DESTDIR="$pkgdir/"
}