summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8cb05701c35..d0dbf04a6821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,21 +12,25 @@ url="https://creekey.io"
license=('UNLICENSED')
prepare() {
+ cd "creekey-cli"
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
+ cd "creekey-cli"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release --all-features
}
check () {
+ cd "creekey-cli"
export RUSTUP_TOOLCHAIN=stable
cargo test --frozen --all-features
}
package() {
+ cd "creekey-cli"
find target/release \
-maxdepth 1 \
-executable \