summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d13ccb1b5b51..aa927328a50b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Opencreek Technogoly UG <hannes@opencreek.tech>
pkgname=creekey-git
-pkgver=0.1.0
-pkgrel=3
+pkgver=0.1.0_r108.82b4efe
+pkgrel=1
makedepends=('git' 'cargo')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
pkgdesc="Story your Private Keys on your Phone!"
@@ -10,6 +10,11 @@ source=("git+https://github.com/opencreek/creekey-cli.git#branch=main")
url="https://creekey.io"
license=('UNLICENSED')
+pkgver() {
+ cd "creekey-cli"
+
+ printf "0.1.0_r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
prepare() {
cd "creekey-cli"