summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a30f76882c3..2c796a131268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname=crispy-doom
pkgdesc="Vanilla-compatible enhanced Doom engine"
-pkgver=3.5
-pkgrel=4
+pkgver=4.0
+pkgrel=1
arch=('i686' 'x86_64')
url="http://fabiangreffrath.github.io/crispy-doom"
license=('GPL2')
depends=('libpng' 'libsamplerate' 'sdl_mixer' 'sdl_net')
makedepends=('python')
optdepends=('freedm: Free deathmatch game'
- 'freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)'
- 'freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)')
+ 'freedoom1: Free Ultimate Doom-compatible game'
+ 'freedoom2: Free Doom II/Final Doom-compatible game')
install=crispy-doom.install
source=(https://github.com/fabiangreffrath/$pkgname/archive/$pkgname-$pkgver.tar.gz
- 0001-man-docgen-simplecpp-Force-UTF-8-reading-and-writing.patch)
-sha512sums=('cc664ec85d8c376075223c8a92e7e70274972fd97a8007abc5936cd020f1555794398676e58231cb19786a2f9bb6b1f01f5152efc4563d3d3f8f62fcb31f3961'
- 'e2702dc1fb684f31abfc443f10bd99409f01ac9540fcecb2dbdd9ff738e50f283314f998bae8569aad7f720a60a12ada4fad443c60ae3320c60ca5638e68361c')
+ 0001-bash-completion-Use-autoconf-substitutions-for-the-c.patch)
+sha512sums=('c5726e6624c367cb0c9f308bc317e19c91b2ce954e03724977116af8782062405de123bbbe5d86858b3bdb44bc3c14f02d2e1cf867b5bcd89233218627c57fb1'
+ '8e3a10bc58bed9ac0623d9962ee3449a8c7dc07cc368445ee2d0a3aea14d1d46074d9655a78a61459683325c8cffee0b1b3c5201010271318c22e0543892357f')
prepare() {
# GitHub's generated archive prefix kind of sucks.
@@ -46,6 +46,5 @@ package() {
cd "$pkgdir"/usr
rm -rf share/man/man5/default.cfg.5 \
- share/man/man6/chocolate-{server,setup}.6 \
- share/bash-completion
+ share/man/man6/chocolate-{server,setup}.6
}