summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a6c57aa4dad..413235915ad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
+# Maintainer: sashok724 <archlinux at sashok724 dot net>
+# Contributor: George Rawlinson <grawlinson@archlinux.org>
# Contributor: aksr <aksr at t-com dot me>
# Contributor: Pavel Borzenkov <pavel@voidptr.ru>
-# Maintainer: sashok724 <archlinux at sashok724 dot net>
_pkgname=criu
pkgname=criu-git
-pkgver=r10517.38012e535
+pkgver=r10915.5b2e5855c
pkgrel=1
-pkgdesc="A Checkpoint/Restore functionality for Linux in Userspace, git version"
-arch=('x86_64')
+pkgdesc="Utilities to checkpoint and restore processes in userspace, git version"
url='https://github.com/checkpoint-restore/criu'
license=('GPL2')
+arch=('x86_64')
provides=('criu')
conflicts=('criu')
-depends=('protobuf-c' 'libnl' 'libnet' 'python' 'python-protobuf')
-makedepends=('xmlto' 'asciidoc' 'git')
source=("git+$url")
-sha256sums=('SKIP')
-options=('!buildflags')
+depends=('libbsd' 'libnet' 'libnl' 'protobuf-c' 'python-protobuf' 'gnutls' 'nftables')
+makedepends=('xmlto' 'asciidoc' 'git')
+options=('!buildflags' '!lto')
+sha256sums=(SKIP)
pkgver() {
cd $_pkgname
@@ -30,9 +31,13 @@ build() {
package() {
cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir/" \
- PREFIX=/usr \
- SBINDIR=/usr/bin \
- LOGROTATEDIR=/etc/logrotate.d \
- LIBDIR=/usr/lib install
+ make DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ SBINDIR=/usr/bin \
+ LIBDIR=/usr/lib \
+ LIBEXECDIR=/usr/lib \
+ install
+
+ # remove empty directory
+ rmdir "$pkgdir/usr/include/compel/common/asm"
}