summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4143e54708cd..2f489fa6ae95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_gonamespc='github.com/schollz/croc'
pkgname=croc
-pkgver=4.1.5
+pkgver=6.0.6
pkgrel=1
pkgdesc="Easily and securely send things from one computer to another."
arch=('x86_64')
@@ -15,6 +15,7 @@ provides=('croc')
conflicts=('croc-bin' 'croc-git')
#options=()
source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('811eee0713b5bdf408dd53a31eff19372da833d46ff36357499c8df4109ec44b')
prepare() {
if [ ! $(wc -w <<< $srcdir) == 1 ]; then echo srcdir can\'t contain spaces because of trimpath; return 1; fi
@@ -31,7 +32,7 @@ build() {
go build -x -ldflags "-X main.version=${pkgver}" -gcflags "all=-trimpath=${srcdir}" $_gonamespc
if [ $(which upx 2>/dev/null) ]; then
echo Compressing ${pkgname} with UPX...
- upx --best "${srcdir}/${pkgname}"; fi
+ upx "${srcdir}/${pkgname}"; fi
}
check() {
@@ -41,4 +42,3 @@ check() {
package() {
install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}
-sha512sums=('ec78407cf7a03133bd572d910c6121d55a996687cc484b1eb361ae487bbccecdbdb651a3ae649421ba097bd4e07c917aba32150f4cf38dc244a406596a37ba10')