summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be1e2b0c9d23..dd5741fa0efc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: rafaqzsu <rafaqzsu [at] gmail (dot) com>
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: rafaqzsu <rafaqzsu [at] gmail (dot) com>
+
pkgname=cropgui-git
-pkgver=349125
+pkgver=0.2.r60.g541e812
pkgrel=1
epoch=1
-pkgdesc="A GTK GUI for lossless JPEG cropping (and rotating)"
+pkgdesc='A GTK GUI for lossless JPEG cropping (and rotating)'
arch=('any')
url="https://emergent.unpythonic.net/01248401946"
license=('GPL')
-depends=('python'
- 'python2-pillow')
+depends=('python' 'python2-pillow' 'libjpeg-turbo' 'imagemagick')
makedepends=('git')
provides=('cropgui')
conflicts=('cropgui')
@@ -16,11 +17,11 @@ source=("$pkgname::git+https://github.com/jepler/cropgui")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
./install.sh -f gtk -t $pkgdir -p /usr -P python2
}