summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24ee76497736..5d63e299e152 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,41 @@
# Maintainer: Shatur <genaloner@gmail.com>
pkgname=crow-translate-git
-pkgver=r26.abe8009
+pkgver=0.9.5.r0.g7c4b066
pkgrel=1
pkgdesc="A simple and lightweight translator that allows to translate and speak the selected text using the Google Translate API"
arch=('x86_64')
url="https://github.com/Shatur95/Crow"
license=('GPL3')
depends=('qt5-base' 'qt5-multimedia' 'gst-plugins-good' 'openssl')
-makedepends=('qt5-tools')
-provides=('crow')
-source=("${pkgname%-*}::git+https://github.com/Shatur95/CrowTranslate.git")
+makedepends=('qt5-tools' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/Shatur95/CrowTranslate.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
# Clone submodules
prepare() {
- cd ${pkgname%-*}
+ cd "${pkgname%-git}"
git submodule init
git submodule update
}
-pkgver() {
- cd ${pkgname%-*}
-
- # Get the version number.
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
build() {
- cd ${pkgname%-*}
+ cd "${pkgname%-git}"
qmake
make
}
package() {
- cd ${pkgname%-*}
+ cd "${pkgname%-git}"
make INSTALL_ROOT="$pkgdir/" install
}