summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5a67411a7d1..d5858d108b26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
+# Maintainer: kmille <github@androidloves.me>
# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
pkgname=cryptboot
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc="Encrypted boot partition manager with UEFI Secure Boot support"
arch=('any')
url="https://github.com/xmikos/cryptboot"
license=('GPL3')
depends=('cryptsetup' 'grub' 'efibootmgr' 'efitools' 'sbsigntools')
-source=(https://github.com/xmikos/cryptboot/archive/v$pkgver.tar.gz)
-sha256sums=('f3227cbe2847d389b6c340a73e26f6859c18f6eef662a7822b5582cfee6d5538')
+source=(https://github.com/kmille/cryptboot/archive/refs/tags/v$pkgver.tar.gz)
+sha256sums=('53863e54be9bcd6bd47ad05b5c0afbcaae139d590106ef098da275adb86f46e6')
package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm755 cryptboot "$pkgdir/usr/bin/cryptboot"
install -Dm755 cryptboot-efikeys "$pkgdir/usr/bin/cryptboot-efikeys"
+ install -Dm755 grub-install "$pkgdir/usr/local/bin/grub-install"
install -Dm644 cryptboot.conf "$pkgdir/etc/cryptboot.conf"
}