summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5abe4b4c0095..dc1cf6d9dc1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,14 @@
# Previous maintainer: spider-mario <spidermario@free.fr>
pkgname=csmith
pkgver=2.2.0
-pkgrel=1
-pkgdesc="Tool for stress-testing compilers, static analyzers, and other tools that process C code"
+pkgrel=2
+pkgdesc='Tool for stress-testing compilers, static analyzers, and other tools that process C code'
arch=('i686' 'x86_64')
-url="http://embed.cs.utah.edu/csmith/"
+url='http://embed.cs.utah.edu/csmith/'
license=('custom:BSD')
depends=('perl')
-source=(csmith.sh
- "https://embed.cs.utah.edu/csmith/${pkgname}-${pkgver}.tar.gz")
-md5sums=('75128bd5310cbc1c139b696da3b8e4d8'
- '05682b96f6607b00426d42718b9c2fd6')
+source=("https://embed.cs.utah.edu/csmith/${pkgname}-${pkgver}.tar.gz")
+md5sums=('05682b96f6607b00426d42718b9c2fd6')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -28,10 +26,6 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}/" install
-
- install --directory "${pkgdir}/etc/profile.d/"
- install ../../csmith.sh "${pkgdir}/etc/profile.d/"
-
install --directory "${pkgdir}/usr/share/licenses/${pkgname}/"
install COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}