summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b8038f4bd36..dc59d73bc7b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Wenxuan <wenxuangm@gmail.com>
+_pkgname=csview
pkgname=csview-git
-_pkgname="csview"
pkgver=0.3.6.48.gca098b0
pkgrel=1
-pkgdesc="A high performance csv viewer with cjk/emoji support"
+pkgdesc='A high performance csv viewer with cjk/emoji support'
arch=(i686 x86_64)
-url="https://github.com/wfxr/csview"
-license=("MIT" "APACHE")
-makedepends=("git" "rust" "cargo")
-conflicts=("csview" "csview-bin")
+url='https://github.com/wfxr/csview'
+license=('MIT' 'APACHE')
+makedepends=('git' 'rust' 'cargo')
+conflicts=("${_pkgname}" "${_pkgname}-bin")
+provides=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/wfxr/csview.git")
+source=("${_pkgname}::git+${url}")
sha256sums=("SKIP")
pkgver() {